준호씨의 블로그

linux - yum whatprovides - 무슨 패키지가 필요 한지 찾는 방법 본문

개발이야기

linux - yum whatprovides - 무슨 패키지가 필요 한지 찾는 방법

준호씨 2018.04.24 23:43
$ ./mailstats
./mailstats: error while loading shared libraries: libdb-4.2.so: cannot open shared object file: No such file or directory

libdb-4.2.so 가 필요 하다고 함.

libdb-4.2.so 를 직접 구해다가 복사 하기도 하지만 yum 으로 설치 할 수 있으면 yum 으로 설치 하는 것이 편하다.

어떤 패키지를 설치 해야 되는지 찾아 보려면 yum whatprovides libdb-4.2.so 를 입력하면 어떤 패키지가 필요 한지 알려 준다.

$ sudo yum whatprovides libdb-4.2.so
Loaded plugins: security, versionlock
compat-db42-4.2.52-15.el6.i686 : The Berkeley DB database 4.2.52 compatibility library
Repo        : RHEL6.0
Matched from:
Other       : libdb-4.2.so

compat-db42-4.2.52-15.el6.i686 : The Berkeley DB database 4.2.52 compatibility library
Repo        : RHEL6.1
Matched from:
Other       : libdb-4.2.so

...

이제 설치 하면 된다.

sudo yum install compat-db42-4.2.52-15.el6.i686
0 Comments
댓글쓰기 폼