관리 메뉴

준호씨의 블로그

ansible 과 python 버전. 오래된 서버에 ansible 환경 세팅하기 본문

개발이야기

ansible 과 python 버전. 오래된 서버에 ansible 환경 세팅하기

준호씨 2016. 2. 21. 00:24
반응형

ansible 을 사용하려면 python 이 필요하다. 배포 대상이 될 리모트 호스트들도 python 이 필요하다. 그리고 가급적이면 python 2.5 이상이 좋다. python 2.4 도 가능은 하지만 python-simplejson 을 별도로 설치 해 주어야 한다.
얼마전 오래된 서버를 대상으로 ansible 배포를 하려고 했는데 안되어서 보니 python 2.3 이 설치 되어 있었다. 그래서 python 부터 설치 해 주어야 했다.
python 2.7 을 설치 했고
/usr/local/bin/python
에 설치 하였다.
그런데 여전히 에러가 났다. 찾아 보니 ansible_python_interpreter: /usr/local/bin/python 설정을 해 주는 방법이 있었다.
group_vars/real, group_vars/dev 파일에
ansible_python_interpreter: /usr/local/bin/python
설정을 넣어 주니 잘 동작하였다.
아마 웬만큼 오래된 서버가 아닌이상 python 2.3 이하가 설치 되어 있을 일은 없겠지만 만약 그런 상황이라면 위와 같이 해결이 가능하니 도움이 되었으면 좋겠다.

python 2.5 이상

그냥 사용 가능

python 2.4

python 2.4 에서는 python-simplejson 을 설치 해 주면 된다.

sudo yum install python-simplejson

python 2.3 이하

python 을 업그레이드 해 주어야 한다.

관련글

반응형
0 Comments
댓글쓰기 폼