준호씨의 블로그

perl Moose 에러 - Invalid version format (version required) 본문

개발이야기

perl Moose 에러 - Invalid version format (version required)

준호씨 2016. 5. 3. 23:17
반응형

맥북에서 perl 환경 프로젝트를 돌리려고 하는데 갑자기 아래와 같은 오류가 나타났다.

Invalid version format (version required) at /Library/Perl/5.18/Module/Runtime.pm line 386.
BEGIN failed 는 use Moose; 하는 부분 이었다.
Moose 와 관련된 문제인거 같긴 한데 잘 모르겠다.

아래 포스팅을 보니 Moose 를 업그레이드 하면 해결 될거라고 한다.

일단 쉽게 에러 재현 하는 방법

$ perl -MMoose -e 1
Invalid version format (version required) at /Library/Perl/5.18/Module/Runtime.pm line 386.
BEGIN failed--compilation aborted.

업그레이드 하는 방법 까지는 설명이 없는데 그냥 cpan 으로 설치 하면 업그레이드 됨
$ sudo cpan Moose
or
$ cpanm Moose

반응형

'개발이야기' 카테고리의 다른 글

osx에 haskell 설치  (0) 2016.05.04
/usr/bin/GET 설치. lwp-request. perl  (0) 2016.05.04
perl Moose 에러 - Invalid version format (version required)  (0) 2016.05.03
docker 주요 명령어  (0) 2016.04.28
나의 vim 설정 (~/.vimrc)  (0) 2016.04.21
sendmail 로그 항목 풀이  (0) 2016.04.18
0 Comments
댓글쓰기 폼