관리 메뉴

준호씨의 블로그

brew 이용해서 ipython basemap 설치 본문

IT이야기

brew 이용해서 ipython basemap 설치

준호씨 2015. 11. 13. 00:03
반응형
basemap 이 설치 되어 있지 않으면

ImportError: No module named 'mpl_toolkits.basemap'

이런 오류가 나옴

설치 방법 찾아 보기

여기 안내 되어 있는 방식은 source 받아 와서 빌드 하고

python setup.py install

하라는데 선호 하는 방식은 아니라 다른 설치 법을 찾아 봄

brew install homebrew/python/matplotlib-basemap

이렇게 설치 하면 뭔가 막 설치 되는데 그래도 못찾음

python 2 용으로 설치 되었으려나?

https://github.com/Homebrew/homebrew-python 에 보니 --with-python3 을 넣는 방법이 있는 거 같아서 진행 해 봄

brew install homebrew/python/matplotlib-basemap --with-python3

이래 저래 진행 하다가 실패
unset PYTHONPATH 해 보라는데 그래도 안됨

반대로
export PYTHONPATH=/usr/local/lib/python3.5/site-packages/

해 보니 뭔가 설치가 되긴 됨

그런데 처음에 ipython notebook 에서 실행하다 보면 Bad key 어쩌고 나옴. 한 번 나오고 안 나오긴 함.

뭐 하다 보면

/usr/local/lib/python3.5/site-packages/matplotlib/collections.py:590: FutureWarning: elementwise comparison failed; returning scalar instead, but in the future will perform elementwise comparison
  if self._edgecolors == str('face'):

이런 문구도 나옴.

하지만 별 다른 문제는 없어 보임.

하여간 brew 이용해서 python3 환경으로 ipython notebook 설정 하는게 쉽지 않다.

깔끔하게 되는 느낌이 안난다;;

역시 그냥 anaconda 쓸걸 그랬나

conda install basemap

이면 된다는데...

음? brew 로 anaconda 설치가 되나?

brew install Caskroom/cask/anaconda

일단 설치 돌려 놓고 오늘은 여기 까지...




반응형
0 Comments
댓글쓰기 폼